1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't launch the game

Discussion in 'Technical Questions' started by Sydjex, May 3, 2020.

Thread Status:
Not open for further replies.
  1. Sydjex

    Sydjex User

    Joined:
    03.05.20
    Messages:
    7
    Likes Received:
    0
    Hello, I'm sorry this question is asked a lot, but I tried everything, I'll explain what I did.
    So, I had the "cannot init d3d OR grf file has problem".
    I tried :
    - Downloading the dbghelp.dll from the pin on the forum, then replacing the one in the game folder. Did not work.
    - Taking the one from the system32 folder, then replacing the one in the game folder. Did not work.
    - Deleted it, it barely worked, I don't have the "cannot init d3d" message anymore, but now I'm stuck at the title screen.

    And I still have both dropdown lists empty. I'll join screenshots to illustrate what I'm saying.
     

    Attached Files:

  2. Aine Yaten

    Aine Yaten User

    Joined:
    13.08.19
    Messages:
    361
    Likes Received:
    63
  3. Sydjex

    Sydjex User

    Joined:
    03.05.20
    Messages:
    7
    Likes Received:
    0
    Hello, sorry, I made this post pretty late at night, I didn't think of putting here my specs.
    I'm using Windows 10.
    I have an AMD R9 Fury card (with up to date drivers)

    Here's the sfc /scannow you asked :

    Microsoft Windows [Version 10.0.18362.778]
    (c) 2019 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>sfc /scannow

    Beginning system scan. This process will take some time.

    Beginning verification phase of system scan.
    Verification 100% complete.

    Windows Resource Protection did not find any integrity violations.

    Edit : I also didn't specify that I'm running it with compatibility mode for Windows XP (Service pack 3) and running it as admin
     
    Last edited: May 3, 2020
  4. casillias

    casillias Technical specialist Innova Group

    Joined:
    05.04.11
    Messages:
    1,851
    Likes Received:
    115
    And this is wrong, protection system does not wrok with compatibility
     
  5. Sydjex

    Sydjex User

    Joined:
    03.05.20
    Messages:
    7
    Likes Received:
    0
    Okay, so I reverted back to no compatibility. Still doesn't work at all. Exactly the same as before ticking the compatibility.
     
  6. casillias

    casillias Technical specialist Innova Group

    Joined:
    05.04.11
    Messages:
    1,851
    Likes Received:
    115
  7. Sydjex

    Sydjex User

    Joined:
    03.05.20
    Messages:
    7
    Likes Received:
    0
    So, I tried, nothing changed with either 19.5.2 as you recommended or even the 15.7.1 I tried afterward. I'm completely lost here, I don't get why I can't play when I played on a private server one year ago.


    So I, for the 12th times, re-installed the game after installing the 15.7.1, this time it's the same state as in my screenshots, but I can hear the BGM, and navigate through the menu with the keyboard. I don't see them, but I can interact with them.
     
    Last edited: May 4, 2020
  8. casillias

    casillias Technical specialist Innova Group

    Joined:
    05.04.11
    Messages:
    1,851
    Likes Received:
    115
    After installing 19.5.2 you still have empty boxes in setup?
     
  9. Sydjex

    Sydjex User

    Joined:
    03.05.20
    Messages:
    7
    Likes Received:
    0
    Yes, exactly the same as before. I'm joining a dxdiag, maybe it can help you.
     

    Attached Files:

  10. casillias

    casillias Technical specialist Innova Group

    Joined:
    05.04.11
    Messages:
    1,851
    Likes Received:
    115
    And you did copy dbghelp.dll from system32 into game folder after? And check setup again
     
  11. Sydjex

    Sydjex User

    Joined:
    03.05.20
    Messages:
    7
    Likes Received:
    0
    Yes, I also tried the one you linked in an other post, the one I got from my system32 folder, nothing changed

    Edit : that's the other post I'm talking about : https://eu.4gameforum.com/threads/663329/
     
  12. Sydjex

    Sydjex User

    Joined:
    03.05.20
    Messages:
    7
    Likes Received:
    0
    Okay, so, last update. I found where it comes from. It must've been a corruption on my DirectX, because I tried to delete it, then install everything again, and now it's working.

    Thanks a lot for your help !
     
  13. casillias

    casillias Technical specialist Innova Group

    Joined:
    05.04.11
    Messages:
    1,851
    Likes Received:
    115
Thread Status:
Not open for further replies.